Aqua blue screen flashes and character pivot broken after 1.16 & 1.17 upgrade.

The engine is not working as expected? Documentation is wrong or out of date? Let us know here!
Forum rules
To receive direct priority support join our Discord server, register your Naninovel copy and ask in #support channel.
Post Reply
Stellar
Posts: 30
Joined: 30 Mar 2021 10:58

Aqua blue screen flashes and character pivot broken after 1.16 & 1.17 upgrade.

Post by Stellar »

Hi,

I've spent hours trying to figure this out, with no luck.

I upgraded to 1.16 public release from a 1.16 pre-public release, and now I get aqua blue screen flashes during some scene transitions, and occasionally on dialogue text. It only happens the first time I play through. If I scrub back and play through the spot a second time, it's fine.

Also, my Layered Characters are screwed up. They're no longer pivoting correctly when I change the look direction. I've compared all my settings to an older pre-upgraded project (which does not have these issues). The settings seem to be identical.

I'm running Unity 2019.4.24 and I attempted the upgrade so that I could use the hideAll "remove:true" option. That option now works but I'm stuck with the issues mentioned above.

Can you help?
Thanks!
Stellar

idaot
Posts: 55
Joined: 01 Aug 2020 08:25

Re: Aqua blue screen flashes and character pivot broken after 1.16 & 1.17 upgrade.

Post by idaot »

I suggest re-importing your Assets folder (right click on Assets -> Re-import) as the update may have messed up with the cache which sometimes causes small hiccups in game flow. As for the Layered characters, there was a recent update that improved auto render canvas calculation for layered actors. Have you compared the white rectangles around the characters to see if they look the same? If you want to manually adjust the size of the rectangle or the auto sizing is not working for you, you can add a Render canvas component to the root of the prefab and adjust the size there.

Stellar
Posts: 30
Joined: 30 Mar 2021 10:58

Re: Aqua blue screen flashes and character pivot broken after 1.16 & 1.17 upgrade.

Post by Stellar »

I re-imported my Assets folder, but I'm still getting random aqua blue boxes and screen flashes. Any other ideas?

I didn't try fixing the character pivot issue yet but after re-importing my assets folder, now my characters don't show on the screen at all. (Their avatars still show).

About fixing the character pivot, you asked "have you compared the white rectangles around the characters...?" Where do I go to see white rectangles?

Thanks for the help. If I can get these issues worked out, my game demo will be finished!

Post Reply